Honda ATV Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I put a brand new all balls wheel bearing in the front knuckle of my 96 300 and torqued the wheel nut on and there is still play. Any comments? Is it possible for the hub in the knuckle to wear out?
 

·
Premium Member
Joined
·
6,555 Posts
Yes, but it's also possible you got crap bearings.

Mic the bearings and make sure they are uniform and the same size as the bearings that came out.

Were the old bearings tight in the knuckle? Were the new bearings hard to get in or did they just drop into place?
 

·
Registered
Joined
·
223 Posts
If the bearing was tight going into the knuckle I would say it's the all balls, I have a 420 that I put all balls in had play, so I ordered new hubs still have play, bearing were tight in the knuckle, I am just going to replace the assembly knuckle and bearing, only oem for me from now on


Sent from my iPad using Tapatalk
 

·
Premium Member
Joined
·
38,619 Posts
my money say's '' all balls'' is your problem ?, or your hub ?, or your knuckle ?. I will NEVER buy any '' all balls'' products again...EVER !.
 
  • Like
Reactions: _Wilson_

·
Premium Member
Joined
·
5,062 Posts
Odds on it's your drive shaft worn down, mine has worn the same way. Best way around it is to clean hub and shaft up, degrease and apply bearing and bush retainer. It's cheaper than buying new hubs and shafts that's for sure.
 

·
Registered
Joined
·
7,361 Posts
If you were able to press the bearing in the knuckle with just your fingers then there lies the issue.

I don't see the issue with the all balls bearings, I have used them a lot. not one issue.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top