Honda ATV Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Coming to the forums to see if anyone else has had this problem. I got a 2004 rancher 350 last week for a pretty cheap price. Knew the plastics were a little rough, needed new tires and wheels, new seat cover, all basic stuff. When I got it home I wanted to give it a wash. I took the seat off because I took the seat cover off and didn’t want to get the foam wet, and covered the battery up with a towel. After the wash, went to turn the key on the wheeler and no lights popped up. Before washing it I could turn the key and turn the headlights on, etc. Is there a chance that it could be because the water got to the battery compartment or in the battery? Hopefully you guys got some answers! Thanks!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Coming to the forums to see if anyone else has had this problem. I got a 2004 rancher 350 last week for a pretty cheap price. Knew the plastics were a little rough, needed new tires and wheels, new seat cover, all basic stuff. When I got it home I wanted to give it a wash. I took the seat off because I took the seat cover off and didn’t want to get the foam wet, and covered the battery up with a towel. After the wash, went to turn the key on the wheeler and no lights popped up. Before washing it I could turn the key and turn the headlights on, etc. Is there a chance that it could be because the water got to the battery compartment or in the battery? Hopefully you guys got some answers! Thanks!
Found out I blew a 15 amp fuse. Thinking this could be the problem
 
1 - 2 of 2 Posts
Top