Honda ATV Forum banner

rincon snapping noise at rocker cover

1773 Views 1 Reply 2 Participants Last post by  shadetree
2005 rincon 650 has a snapping noise after I installed the rocker cover. seems to do it when the valves close ( pushrod going down). went into it to install new camshaft, timing chain, guides etc. Only turning it over slowly with pull rope to be sure rocker followers are engaging with pushrods. never noticed noise before and not sure if it is ok or not. Have removed rocker cover several times to be sure rockers/rods are meshing. any advice appreciated.
1 - 1 of 2 Posts
2005 rincon 650 has a snapping noise after I installed the rocker cover. seems to do it when the valves close ( pushrod going down). went into it to install new camshaft, timing chain, guides etc. Only turning it over slowly with pull rope to be sure rocker followers are engaging with pushrods. never noticed noise before and not sure if it is ok or not. Have removed rocker cover several times to be sure rockers/rods are meshing. any advice appreciated.
sounds like your cam isnt right to me...did you install a new cam ?..or used one ?..perhaps you got the timming off some how when you replaced all of those parts..i would go back into it..and recheck all of your work..if the lower parts are good..then this makes me think your rocker arms or valves isn't set right.
1 - 1 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top