Honda ATV Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
My friends 2005 Rancher has the push button shift and sometimes it will not work , then it will .
Could this be because of a low battery or what ?
He has went through about 3 batteries in 5 years . Or is this another problem ?
 

·
Registered
Joined
·
347 Posts
Angle sensor?
 

·
Registered
Joined
·
1,873 Posts
Clean and dielectric grease the electrical connections on the motor and ecm.
 

·
Registered
Joined
·
2,392 Posts
clean it and put it back on
 

·
Registered
Joined
·
43 Posts
Discussion Starter #5
Clean and dielectric grease the electrical connections on the motor and ecm.
Can you be a little more specific . And I am not being a smartbutt , I am just a little new to electric shift 4 wheelers . Mine are manual shift .
Do you mean the electrical connections on the engine and on the ECU (brain of the ATV? ) ?
If so , can you show a pic of what it looks like ?
 

·
Registered
Joined
·
2,392 Posts
the shifter take it apart
 

·
Registered
Joined
·
2,392 Posts
yah i agree^^^
 

·
Registered
Joined
·
2,392 Posts
yah thats what i mean
 

·
Registered
Joined
·
2,392 Posts
yap thats wat u do
 

·
Registered
Joined
·
46 Posts
The terminals on the shifter motor are probley corroded. Unplug the motor clean with some type of cleaner and put electrical grease on them. The motor should be located in the front of the trans behind the right tire. If that does not work pull shifter motor apart and clean the armiture, not too hard to do I have done on several.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #14
The terminals on the shifter motor are probley corroded. Unplug the motor clean with some type of cleaner and put electrical grease on them. The motor should be located in the front of the trans behind the right tire. If that does not work pull shifter motor apart and clean the armiture, not too hard to do I have done on several.
I'll try that , if I can find the motor . Thanks!
 

·
Registered
Joined
·
3 Posts
I am new to the site but have two rancher 350's ( 2002). The shifter always acts baD with a weaker battery. I have chnaged batteries twice with this issue and it has corrected each time.
 

·
Premium Member
Joined
·
7,533 Posts
I am new to the site but have two rancher 350's ( 2002). The shifter always acts baD with a weaker battery. I have chnaged batteries twice with this issue and it has corrected each time.
Welcome to the forum but you may want to start a new thread so it wont get lost in this one .
 
1 - 16 of 16 Posts
Top