Honda ATV Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I'm an idiot. Should have checked this first before spending $195 on a new PCM.
Everything in the shop manual was for troubleshooting a blinking "- -" on the display. Mine wasn't blinking. Got to thinking that maybe it was the Drive gear position switch or a short in the wiring between the GPS and the PCM.
I was getting a solid non-blinking "- -" when in "D".
Did the continuity test starting from the PCM to the 4P connector & then from the 4P connector to the gear position switch plugs. All checked out good.
Took out the Drive gear position switch & swapped it with the Neutral gear position switch (they appear to be identical).
I now have "D", "N" which now has the faulty GPS from "D" lights up either "N" or "- -" if I fiddle with the shift knob I can get it to stay lit in "N" & I got "R".

Got a new Gear Position Switch on order & I should be good to go!

Still have one brand new PCM, still in the box that I can't return. Will sell it for half price to anyone that needs one!

Many Thanks to all the offerred their assistance!
Ol'Roy
 

·
Registered
Joined
·
3,572 Posts
That sucks that you had to buy a PCM, just hold onto it you might need it someday.
 

·
Premium Member
Joined
·
23,581 Posts
I'm glad to hear you got it figured out.
 

·
Registered
Joined
·
33 Posts
So it was one of the gear position sensors? Mine will show drive and reverse, but not Neutral. I'll try swapping the sensors (Drive and Neutral) and see if I can perform the initialization. I can't even do that, which is the bummer because I've put in so many new components I'm sure it is mechanically sound and ready to go. It has to be a sensor or electronic issue.....
 
1 - 6 of 6 Posts
Top