Honda ATV Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
No spark on my 1998 foreman 450 . I have checked so far the kill switch ,all fuses the coil the spark plug the voltage regulator all above are know to be good . I have replaced the cdi box the stator / pick up coil . Also cleaned all ground connections . Battery is good .I'm stumped .
 

·
Premium Member
Joined
·
5,956 Posts
The ignition switch check out ok too? Did you replace with OEM parts only? It could be something as simple as a dirty/corroded harness plug connection somewhere. Or an engine or frame ground corroded or loose...? Does the neutral indicator work?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I have cleaned all grounds to frame and checked the ignition swtich it's good the new cdi box is from honda all the other parts work on my foreman 400 that runs great I was unsure if the cdi box would interchange with the 400 so I got a factory honda cdi box
 

·
Premium Member
Joined
·
5,956 Posts
I don't have the service manual for the 98 450 ES, so I don't know if this is relevant or not... but does the oil temp control module shut down the ignition if it detects an overheated condition? If so, troubleshoot the oil temp sensor and module circuits.

Edit:
This is probably irrelevant, but does the display function like it should? Everything work on it? Doesn't reset itself or flicker the oil temp light?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
The oil temp light was on the wire going to the oil temp sensor was broken I spliced it back together and now it is on but it's just kinda a dim glow and the the display does not show the center of the screen but what you can see seems to work the way it should all the buttons work you just can't see a small part of the middle of it . I don't know if a oil temp will stop it from starting
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Thanks retro for the link the service manual was a big help . I replaced the stator with a Honda stator. the man I bought it from had replaced the stator with a aftermarket one that was bad . I cleaned the carb and gas tank and she fired right up after two years sitting in a barn. Thanks again retro .
 

·
Registered
Joined
·
1 Posts
New coil new plug new cdi new regulator new key switch fresh battery tested exciter and stator changed all fuses bypassed handlebar switch grounded numeral saftey switch still no spark 99 foreman 450
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top