Honda ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi
I'm very happy to be here, I got my first ATV, 2000 Honda Recon, very busted up but Its a my project, I really never use a forum before and been honest I already receive a good help here for one amazing user cmanningjr.

Well my little Recon was running rough and I though was an electric issue, at 1/4 throttle was like Sneezing and then all lights flashing, was charging the battery fine that make me think can't be an electric issue, cmanningjr shared it with me the service manual and was on that moment when I realize my Recon has the wrong carburetor.
Friday night I got a new OEM carb for my guy and now is running like a champion, today was the first time when I toked to the small mud and I'm very happy is very fun, I added some lights because the head lights doesn't work very well and I been cleaning and restoring the rack, also waiting for a new seat coming on wednesday.

I'm going to add some pics,

BTW sorry if my English is not very good but English is not my first language.

Thanks for let me enjoy your forum

Ozzy

20170901_200949.jpg

20170901_200956.jpg

20170901_201001.jpg

20170901_201007.jpg

20170901_203342.jpg
 

·
Registered
Joined
·
2,810 Posts
Glad you got your carb issue straightened out.

That's not a bad looking Recon.. you should see the POS I have.. lol


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
190 Posts
Welcome Ozzy, glad to have ya man! I'm a newbie myself and these guys are more than hospitable to say the least. Tons of knowledge right here, absolutely amazing! Congrats on your new toy!
 

·
Super Moderator
Joined
·
5,062 Posts
Welcome aboard Ozzy
 

·
Registered
Joined
·
4,691 Posts
Welcome to the forums!
 
1 - 5 of 5 Posts
Top