Honda ATV Forum banner

1 - 6 of 6 Posts

Registered
Joined
72 Posts
Discussion Starter #1
I got a 2003 Honda rancher 350, and when I start it, it will run great for about 5 minutes and then blow the main fuse out need help I don't know anything about electrical stuff

Sent from my XT1609 using Tapatalk
 

Premium Member
Joined
4,702 Posts
If it's blowing a fuse you have a hot wire touching a ground somewhere. Actually a good sign cuz it will tell the tech exactly where to look. If you have the service manual you could look at the wiring diagram and try tracing the main bus. Otherwise electrical gremlins can kick a mans butt
 

Premium Member
Joined
5,956 Posts
A number of things can cause the main fuse to blow every few minutes. I would look for any chaffed wires rubbing on the frame or motor somewhere first. While you are at it, pull apart every plug connector and look for corrosion and clean the two grounds and both of the battery cables. Then check the ignition switch... feel the switch body to see if it is getting warm...? Then check the kill switch (has it gotten water in it?) and use your multimeter to check the regulator/rectifier. You should gain a clue or two by that time....
 

Registered
Joined
72 Posts
Discussion Starter #4
Aight thank y'all, and yes it's been sunk past the handle bars a number of times

Sent from my XT1609 using Tapatalk
 

Premium Member
Joined
5,956 Posts
Aight thank y'all, and yes it's been sunk past the handle bars a number of times

Sent from my XT1609 using Tapatalk

Maybe something is still wet and corroding then... switches and plugs can turn blue and get fuzzy with corrosion pretty quick! I'd grab a can of WD-40 or CorrosionX if ya got some and open everything up and shoot it. Might have 'er fixed in no time if its just a water problem...
 
1 - 6 of 6 Posts
Top