Honda ATV Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi there, i have just bought a moto roma geko 300cc. After trawling the net i have been informed that its got a honda trx 300 engine in it. I have fitted a new throttle cable and twistgrip but i cant get it to idle very well. It starts and runs but revs a bit too ghigh, i cant seem to find a carb online the same as mine. The only adjuster i can see is a screw at the end of a pipe. I cannot find how to adjust this to try to make it run a bit better. It has to be fully wound one way or another then adjusted out but i am at a loss as to where to even start with this. All or any help much appreciated. Rickus
 

·
Super Moderator
Joined
·
38,618 Posts
no..it does not have a trx300 engine in it, if it did ?, then it would be called a trx300, and you would not be having issues with it not working right, spec with a china carb maybe in it ?.
 

·
Registered
Joined
·
1 Posts
Hi there, i have just bought a moto roma geko 300cc. After trawling the net i have been informed that its got a honda trx 300 engine in it. I have fitted a new throttle cable and twistgrip but i cant get it to idle very well. It starts and runs but revs a bit too ghigh, i cant seem to find a carb online the same as mine. The only adjuster i can see is a screw at the end of a pipe. I cannot find how to adjust this to try to make it run a bit better. It has to be fully wound one way or another then adjusted out but i am at a loss as to where to even start with this. All or any help much appreciated. Rickus
Did you ever get sorted with the problem ? I bought a roma geko 300 need few parts having trouble getting them
 
1 - 3 of 3 Posts
Top