Honda ATV Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
i have a 04 trx450r and im having a issue that i believe may be an spark issue. the quad runs fine cold and has no issues with idling. when the quad warms up to normal operating temps, it does not want to idle and throttle response is low. could the stator be going bad when the heat of the motor warms it up?


thanks
 

·
Premium Member
Joined
·
23,581 Posts
Welcome to the forums. It could be a firing problem, but it sounds a lot like a carb problem, too. The idle circuit might be about stopped up.

If it's a firing problem, it sounds more like it could be the ignition coil getting hot. Usually the stator is just the opposite when they go bad. Usually they don't want to start when they are cold and you have to push them off, but when they get warm, they start alright.
 

·
Premium Member
Joined
·
23,581 Posts
Did you take the fuel hose off the carb and make sure it's getting plenty fuel to the carb? Did you check the rubber intake boot for leaks?

I guess it could be the stator, but like I said, they usually do just the opposite. Maybe not this time, though. Have you checked to see if you're getting a good, bright blue spark at the spark plug after it warms up and starts acting up?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
ive checked the fuel line and i havent found any leaks yet but i have not checked to see if there is a bright blue spark
 

·
Premium Member
Joined
·
23,581 Posts
ive checked the fuel line and i havent found any leaks yet but i have not checked to see if there is a bright blue spark
I would wait to it warms up and starts acting up, then I would check to make sure it has a good, bright blue spark. If it has a weak spark, then you will know for sure it is a firing problem. If it's got a weak spark, since you've already replaced the ignition coil, then the only other things left are the stator, pulse generator, or CDI. In my experience, when the CDI or pulse generator goes bad, they usually go bad all at once and won't run at all, so it might be the stator.
 

·
Premium Member
Joined
·
23,581 Posts
1 - 8 of 8 Posts
Top