Honda ATV Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Looking at the pic below, do you see a problem. I replaced the old one because it looks to be stuck open, is that what the pic shows?

My rancher would not idle once warmed up. I haven't been able to check it since we have the rearend out, but hope to tomorrow.
 

Attachments

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Well that didn't work....

Any more ideas guys? I've replaced the injector, idle air control valve and the intake temp. sensor. I've checked the wiring somewhat, but need to find a diagram and really get into it. Any suggestions of areas to look first?

Thanx, Duke
 

·
Registered
Joined
·
405 Posts
Is the FI light flashing any codes? Some other possibilities: clogged fuel filter inside fuel pump, try replacing spark plug, bad throttle position sensor, throttle body throat caked with carbon build up, valve clearances need adjustment(.15mm int/.22mm exh).
 

·
Registered
Joined
·
1,969 Posts
Does the Rancher FI have an additional filter screen where the fuel comes in? Some injectors do and they can clog with trash and effect fuel flow. Maybe there is a diagram of the injection in the manual showing all parts of it,,or someone here has cleaned one before and could tell you. A fuel pressure check would be a good idea. You can make your own,,do a search on YT to show you how,,,its not expensive to make one. Good luck.
 

·
Registered
Joined
·
405 Posts
There aren't any additional filters if the bike is stock, the fuel goes straight from the tank to the pump then from the pump to the injector. It's no use trying to clean the filter inside the pump, if that's the problem, just get a new one. Check your fuel pressure as stu says and if you take the pump apart, check the green and red wires inside to make sure they are making solid contact, I had a pump that would kick in and out intermittently, found out there was a loose wire inside the pump.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7 (Edited)
Thank you guys. The only thing I hadn't suspected was the TPS. But that makes sense. I have done everything on your list Sabre except that and the fuel filter, but the pump is only a month old. Although the kid I bought this from probably used bad gas so I think I will tear the pump apart and check everything.

Oh and no codes flashing.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Fixed... I listened to the IAC valve and it was clicking very fast when the key was first turned on and again once the engine was warm. I unplugged it while it was running waited a few seconds and plugged it back in. This did throw a code and the FI light started flashing, but the idle raised to ~1400 and I could rev it and let off and it would idle. Shut the key off waited 10 seconds and fired it back up and my idle is spot on and rock steady.
 

·
Registered
Joined
·
83 Posts
Looking at the pic below, do you see a problem. I replaced the old one because it looks to be stuck open, is that what the pic shows?

My rancher would not idle once warmed up. I haven't been able to check it since we have the rearend out, but hope to tomorrow.
can you please tell me how to remove those screws? do i need a special screw driver? it has those weird pins in the center..
 

·
Registered
Joined
·
1 Posts
I have a 2012 Honda rancher 420 4x4 it idles really rough it idles high and the screw that you use it idles it down doesn't work cleaned carb still does it does any body have a clue does idle low sounds like it back fires as well
 

·
Premium Member
Joined
·
3,310 Posts
Fixed... I listened to the IAC valve and it was clicking very fast when the key was first turned on and again once the engine was warm. I unplugged it while it was running waited a few seconds and plugged it back in. This did throw a code and the FI light started flashing, but the idle raised to ~1400 and I could rev it and let off and it would idle. Shut the key off waited 10 seconds and fired it back up and my idle is spot on and rock steady.
Did you try the above?
Do you have the service manual? Link in my sig block.
It would be best for you to start a fresh thread addressing your 2012 as this thread was originally for 2007 and several years old
 

Attachments

·
Registered
Joined
·
3 Posts
Hey buddy I am having some problems with my 2013 honda foreman sounds like the same problem you was having! What is the IAC because I changed everything from the fuel pump to the injector still can not start unless I shot gas straight to the TB! I am out of options and need help I am not getting enough fuel for sure!
 
1 - 13 of 13 Posts
About this Discussion
12 Replies
8 Participants
Koro
Honda ATV Forum
We’re a forum community dedicated to Honda ATV owners & enthusiasts. Come join the discussion about upgrades and reliability for your Rancher, Foreman, Recon, FourTrax, Pioneer, and more!
Full Forum Listing
Top