Honda ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Whats up guys? New to this forum and wanted to get some advice on what may be wrong with my wheeler. It hasn't set up long, but with hunting season right around the corner I was going to run it the other day. Problem is I didnt get very far. It starts fine, but will not rev up. Its like it floods out or something when I rev it up. I was able to ride it around the yard but I had to keep the choke pulled. This is what I have done so far. I have drained the carb. Drained the gas and replaced with new and I have changed the spark plug, but still nothing. There is a pretty good bit of oil in the air box.Was planning on trying to fix it tomorrow and thought I would ask here for advice first. Sorry for being so long winded.
 

·
Registered
Joined
·
42 Posts
carb is going to need a cleaning make sure the low speed jet is clear.they do not have to sit long this day and time for the gas to go bad and stop up the low speed jet
 

·
Premium Member
Joined
·
23,581 Posts
Welcome to the forums. X2 on the carb needing to be cleaned.
 

·
Premium Member
Joined
·
38,518 Posts
agreed ^^^^^^..dirty carb..give it a good cleaning..oh..never run your bike with the choke on for very long..this will kill your rings very quickly...also..your high jet is what is giving you problems..give the carb a good cleaning..this will fix you up.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Just got it back on and its running good. Messes my air filter up in the process though. It was time for a new one anyways. Are the K & Ns worth the extra money??
 
1 - 5 of 5 Posts
Top