Honda ATV Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I have acquired a 1988 TRX350 that has been sitting for years and just found this site a few days ago. After a small bit of tinkering today I got it to where it will crank. I have a few questions but I'll post them in the appropriate forums. Looking forward to getting this bike going!







 

·
Super Moderator
Joined
·
5,062 Posts
Damn, where do you guys find these 350's! Especially in Blue, mmmm blueee!

Welcome to the forums :)
 

·
Registered
Joined
·
4,691 Posts
Welcome to the forums! Man alive two more tanks! ?
 

·
Registered
Joined
·
8,309 Posts
welcome to the site
I sure hope you did some basic's here before going forward
like all fluids changed, so you don't end up with bigger issue'
s from running on old oils?


nice find and congrats to you, best of luck getting it going too!
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
welcome to the site
I sure hope you did some basic's here before going forward
like all fluids changed, so you don't end up with bigger issue'
s from running on old oils?


nice find and congrats to you, best of luck getting it going too!
Yes...that was the first thing on my list. After that I made sure it had good compression and was firing. Now I have a problem with the fuel pump not getting any juice. I checked the power where it connects to the wiring harness with a test light but it didn't hit.
 

·
Registered
Joined
·
711 Posts
love the blue. Sweet quad.
 

·
Premium Member
Joined
·
5,956 Posts
Wow! Another purdy tank!!!

You'll have that fuel pump running in no time.

Welcome to the forums!
 

·
Premium Member
Joined
·
38,518 Posts
welcome to the forums. odds are, your fuel cut-off relay is bad ?, or the fuel pump itself is bad ?. unhook the fuel pump from the harness, hook 12 volt dc from a good battery straight to the fuel pump, see if it pumps ?..DO NOT RUN IT DRY MORE THAN A COUPLE SEC'S !!!!.
 
1 - 10 of 10 Posts
Top