Honda ATV Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
After reading several threads I believe my fuel pump is probably bad. My dealer tells me that it is not part of the recall (2019). I do not want to just go replacing a $200 fuel pump. So, here is my question as I try to diagnose. I pulled the fuel line from the fuel pump to the throttle body/injector and replaced it with a line to a gallon jug. I turn the key on and hear the injector clicking. Only about 5 tablespoons of gas are pumped (immediately), then nothing. Try a second time absolutely nothing is pumped. Try again 30 minutes later, another 5 tablespoons of gas. Seems to me the filter could be clogged (low mileage/ hours and very clean) and only letting small amounts of gas get to the pump over time. With the pump pumping into a jug and not building pressure shouldn’t it pump continuously? Thx for any insights/help.
 

·
Registered
2020 520 rubicon foot shift
Joined
·
642 Posts
When the motor isnt running the fuel pump will only run for a few seconds at a time, that part is normal but it should pump the same amount every time you turn the key off then back on.
Pull the pump and check the filter, if its brown/black and looks dirty it's the problem.
This issue was very common on my last atv (750 king quad), the fuel pump filters are very fine and easy to plug on all atv's.

I run a lawn mower inline fuel filter on all my atv's gas tank vents now, the in tank filters last forever this way. The stock set up pulls dust into the tank through the vent.
 
1 - 2 of 2 Posts
Top