Honda ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I'm all of a sudden having electrical problems with my 2017 Honda Pioneer. The battery seems to be low and when I put the charger on it, it still won't start and makes a buzzing noise from the engine compartment. The dash lights are also flickering. If anyone can give me a clue what may be causing this I would appreciate it. I probably don't have 200 miles on this unit.
I hate to take it into the dealer if it's something simple I can fix.
Thanks,
Tony
 

·
Registered
Joined
·
27 Posts
Does the quad sit out in freezing temps in the winter? Sounds like it froze the battery. When this happens, the lead plates can fracture and turn a 400 amp hour battery into a 100 amp hour batt. Best way to avoid it? Make sure the batt is fully charged all winter (float charger).
 

·
Registered
Joined
·
8,191 Posts
also check all your connections to make sure there clean and solid, and all fuses are good!

low battery will give a LOT of issue's and these new atv's/utv's/sxs's
all draw a lot of power even when parked, so if you don't keep them on a maintainer, battery life can be very short!
so I agree, have battery load tested to at least rule it out, and NOT just a voltage reading on a meter, but load tested!
auto parts store test for free!
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
4 Participants
mrbb
Honda ATV Forum
We’re a forum community dedicated to Honda ATV owners & enthusiasts. Come join the discussion about upgrades and reliability for your Rancher, Foreman, Recon, FourTrax, Pioneer, and more!
Full Forum Listing
Top