Honda ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have 96 Honda fourtrax which I've recently installed a new cam chain. I'm now trying to reassemble the clutch cover, however, the cover seems to get stuck at about 1/4 of an inch left. I followed 01SSRedA4's "Honda Fourtrax EPI clutch install How To!" write to make sure I had the kick starter, reverse lockout, and shift level positioned correctly.

Does anyone have any tricks/trips to getting this thing installed, or do I have something installed incorrectly? Your help is much appreciated.

Photos of my current set up:
149535
149536
149537
149538


Thanks in adance.
 

·
Super Moderator
Joined
·
38,511 Posts
it all looks correct from what I see ?. only thing that could posb keep the cover from going back on is maybe the end of the crank not seating in the cover bearing ?. try installing bolts in a criss cross pattern, tapping cover on lightly !!, then see if cover goes on ?.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thank you for your reply. Thats what got me back in the garage. So I’m dumb and didn’t reinstall the exhaust after taking the head off. A small part of the case was hitting it preventing me from getting it installed all the way...

So many hours spent scratching my head. Thanks again.
 

·
Super Moderator
Joined
·
38,511 Posts
Thank you for your reply. Thats what got me back in the garage. So I’m dumb and didn’t reinstall the exhaust after taking the head off. A small part of the case was hitting it preventing me from getting it installed all the way...

So many hours spent scratching my head. Thanks again.
haha..all good, you can find some great advice, members here ---> atvhonda.com , this is where we hang our hats now.
 
1 - 4 of 4 Posts
Top