Honda ATV Forum banner

Classic trx300 no spark thread???

999 Views 4 Replies 3 Participants Last post by  Iguezz300
Hey guys, new to the forum. I’ve followed everyone for a while now. I work on buddies bike on the side and always get good info here but may have to finally admit defeat on one. Im working on a 95 trx300 2WD in near perfect condition. It’s used on a small acerage farm mainly for hauling feed and small things around. Sleeps in the shop every night since new and still with the original owner. Everything is original, plastics and racks are even perfect. (Just giving back ground on condition of bike) anyway, running fine. Stopped to open a pasture fence, died while idleing. Pushed to shop, no spark. Since then I’ve performed all ohm test per the manual I believe. Changed CDI (beat on both while cranking), changed coil, continually test with 2 different brand new spark plugs. Fuses good, voltage at cdi. Continuity with all 3 yellow wires from alt, spark generator test good. Took apart handlebar switch. Only test I can’t perform is peak voltage. I’m stumped guys. Is there something I’m missing or a secret I don’t know about?? I’ve just learned about this small diode under the front plastics. Could that be my issue? If so how do I test it? Any help would be greatly appreciated. Thanks
1 - 2 of 5 Posts
Thanks for the replies. Been out of town with some shady cell service. So far... I’ve tested reverse and neutral circuits, all wires at cdi per manual ( ohm readings only, I don’t have a peak voltage tester) the 3 yellow alt wires, and the spark trigger, took apart all connections coming from handlebars and tested all switches. Tested diode per manual. Yes the neutral light comes on only in neutral. Reverse light works as it should, oil temp light comes on for about 3 seconds when key is turned on then goes off. I’ve even read the wire schematic and tested all wires through the bike that should have voltage to make sure they do. Tested ground all over bike. New OEM coil, new NGK spark plugs..... I did cheap it with an off brand CDI though. With everything I’ve tested, it’s either something testing good on ohms that still doesn’t work, or a bad CDI. I tried the tapping technique with the old and new cdi with no change. I don’t want to spend $200 on something I can’t return of that doesn’t fix the problem. But I’m running out of options.
See less See more
1 - 2 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.