Honda ATV Forum banner

97 fourtrax 300 no power or ignition

15020 Views 13 Replies 4 Participants Last post by  retro
Alright so I just bought this quad. When I bought it I had to replace the ignition switch, so I did. I had yet to buy a battery so I tried to kick start it. The neutral light would light up but I had no spark. I put a battery in it and the solenoid was bad so I just jumped the solenoid and the quad would turn over but still no spark. I ordered a new coil and solenoid, replaced the parts and now I have nothing. No neutral light, nothing happens when I jump the solenoid. I had a spare kill switch panel and installed it as well, this didn't make a difference. Sorry for the lengthiness but I'm tryin to relay all the Info. Thanks for any help.
1 - 1 of 14 Posts
until you get the neutral/reverse switch fixed ?, it won't fire the spark plug.
1 - 1 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.