Honda ATV Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
95 300. Been parked for years. Pulled and cleaned gas tank and carb. New shindy kit in the carb. Carb adjusted to factory settings per service manual. I have a high idle. When I rev it it becomes a hanging idle. (Takes a while to return to the obscenely high idle) I’ve had the carb apart a few times now just double checking my work and can’t seem to fine anything. The obvious works as intended. Throttle snaps back as designed, choke raises rpm when on, mixture screw raises idle when I fatten it (back it out)and lowers idle as it’s leaned out (crank the screw in)

What am I missing? This isn’t rocket science :grin

Now just for fun I moved the e clip up on the needle to the last (highest) position and the idle comes closer to where it should be but chokes and wants to stall if given throttle. What am I missing? It’s gotta be stupid simple. Any suggestions?

Thanks
 

·
Super Moderator
Joined
·
36,820 Posts
put the c-clip back where it goes !. run it through another cleaning. check the diaphragm under the top cap. check to make sure the enrichment valve ( choke valve ) is fully seating when closed. check for a leaking intake boot from being cracked ?. correct air filter ?, oem snorkel stopped up from dirt dobbers ?. idle jet clear ?. plenty of fuel reaching carb ?. 9 out of 10 times, when they run at high idle ?, its either from wrong fuel mixture ?, not enough fuel in carb bowl ?, or an air leak between the carb and intake boot ?.
 
1 - 2 of 2 Posts
Top