Honda ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I have a 92 TRX250X it usually starts right up, but once you try and ride away, about 70% of the time it has no power, if you hold throttle wide open it almost sounds like it hits the rev limiter right away just above idle, I've removed and cleaned the carb twice thinking it was clogged somewhere, remove all jets cleaned etc. A friend said it MAY be electrical, so what parts or area should I be looking at for the electrical??? Yes I'm finally gonna go get a manual for it.
 

·
Registered
Joined
·
1,373 Posts
Did it just start doing it? It sounds like your jetting may be off

Rob
 

·
Premium Member
Joined
·
6,616 Posts
Remove the Petcock valve from the bottom of the gas tank and make sure there is no muck in there. Do not use gas with ANY ethanol in it, make sure you have fresh gas
 

·
Super Moderator
Joined
·
18,228 Posts
YOur coil may be the issue try testing the coil to make sure it is within spec. or it's possible you may have something going on with the timing or valve adjustment
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #5 ·
I'm gonna try all that, well almost, Ive already took apart, clean, and replaced jets. it does NOT do this all the time, just about 60-70% of the time, so Im thinking maybe short in wire harness to, but lucky me I have 2 of the 92 TRX250X's so I can swap parts to see what is wrong, i hope!!!! Thanks agin for the ideas, keep them coming and I'll you know when I find out what it is for sure
 

·
Super Moderator
Joined
·
18,228 Posts
Check your Grounds.... Remove them and clean the frame put die electric grease on them and all connectors and try it.
 
1 - 6 of 6 Posts
Top