Honda ATV Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
My son's trx 125 will run fine for about 10 minutes or so then dies and will start back up and run for about 5 seconds then die again and so on. Could this be a cdi issue or a carb issue. Any advice is appreciated.
 

·
Premium Member
Joined
·
6,616 Posts
Sounds like once it is warm it dies... correct? Does it alway fire right back up but then die, or do you have to let it cool down and then fire it up?

Welcome to the site...
 

·
Super Moderator
Joined
·
18,227 Posts
Agree ^^^^^ also have you cleaned or replaced the air filter lately?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
air filter is good and it will fire right back up no cooling down time. i have the carb apart now and have cleaned on of the jets going to put it back together and see what happens.
 

·
Super Moderator
Joined
·
18,227 Posts
Make sure you remove the idle circuit needle or slow jet as it's called and clean every orfice really good on the needles and carb, with carb and choke cleaner.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
ok put it all back together and nothing. oh and new battery was completely drained. now thinking mught have a short somewhere. Would a direct short give me the same symptoms i explained earlier. thanks again.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
ok i think it's the cdi, i tested the exciter coil, ignition coil, and pulser generator and all were ok according to the service manual specs
 

·
Registered
Joined
·
163 Posts
check the gas flow, carb could be clogged, cdi possibly. trx 125 run great im selling mine
 

·
Registered
Joined
·
10 Posts
Discussion Starter #12
ok got a used cdi from local shop. Put it on ran for about 5 seconds again then nothin. Could something be frying the cdi box voltage reg. maybe , got to fix this thing it was a gift for my son on christmas and he's only rode twice ugh this sucks.
 

·
Super Moderator
Joined
·
18,227 Posts
Does it have a fuse panel? if so I can tell you how to check for drainage if your not sure how to?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #14
Could someone answer my question? Was wandering if a bad regulator would allow enough voltage to burn out the cdi box. I checked the regulator today and it was not in the factory specs. I think i need to find a new regulator and new cdi box and that should solve my problem.
 

·
Premium Member
Joined
·
6,616 Posts
Anytime that something electrical is receiving a stronger current than it is designed to take, it could absolutely fry it.
 

·
Super Moderator
Joined
·
18,227 Posts
Agree ^^^^^^^^ what kind of manual are you refrencing from? and have you Ohm'd out the CDI to make sure it's not bad.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #17
I have the factory service manual. I didn't see any specs to ohm the cdi box. I did perform all the tests in the service manual. If there is a way to ohm test the cdi box let me know. thanks.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #18
Finally!!!!!!!!

I finally just scrapped the whole elecrtical system and rebuilt the carb and it now runs but....... When you run it at more than half throttle or so and release the throttle it idles very high. I know its not the idle screw or the throttle sticking. I wonder if the carb could be loading up with feul or something. I will screw in pilot screw some and see if this fixes it.
 

·
Super Moderator
Joined
·
18,227 Posts
Agree^^^^ on the cable comment but I would lean more towards the Idle circuit.
 
1 - 20 of 21 Posts
Top