Honda ATV Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
23,581 Posts
Discussion Starter #1 (Edited)
I just bought a 2000 Foreman 400 and the speedometer is not working and the odometer does not work, but the hour meter still works. Does any body have any ideal what the problem could be and how to go about checking it? Maybe the speed sensor? Also, there is a tiny green light, located above the hour meter, that blinks on and off. Is it supposed to do this, and what does it mean? It doesn't have a digital dash. Any help would be greatly appreciated. Thanks.
 

·
Premium Member
Joined
·
23,581 Posts
Discussion Starter #2
Does anybody know anything about these speedometers?
 

·
Premium Member
Joined
·
23,581 Posts
Discussion Starter #3
I think maybe the tiny green blinking light means that the engine is running and the hour meter is working. Anybody know for sure?
 

·
Registered
Joined
·
118 Posts
Helmet, did you ever get this problem sorted out. If so, I am interested in what you found. The speedo on my 2001 350(digital) is not working and I am not sure if it is the sensor or the meter unit itself.
 

·
Premium Member
Joined
·
23,581 Posts
Discussion Starter #5
Helmet, did you ever get this problem sorted out. If so, I am interested in what you found. The speedo on my 2001 350(digital) is not working and I am not sure if it is the sensor or the meter unit itself.
I just ended up replacing the speed sensor and that was the problem.
 

·
Registered
Joined
·
40 Posts
I think maybe the tiny green blinking light means that the engine is running and the hour meter is working. Anybody know for sure?
I'm sure you found out about this already. The green light means the hour meter is working. I found that in the owners manual.
 
1 - 7 of 7 Posts
Top