Honda ATV Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello everyone, new to forum but have been reading on here and other forums for weeks for help and info on the issues I am having and still no luck. The bike is 2005 trx300ex I bought for my girl friend to ride. Ran decent when I first got it except previous owner had sprocket welded to output shaft so I split cases and installed a new one. Now the problem is after not even a quarter throttle it cuts out like its hitting a rev limiter almost and will do this threw the hole throttle length no matter what. If I just barely touch the throttle it will run ok. Also sometimes when messing with it, it will run ok for about 2 mins then start doing it. Here is everything I have checked and tried to The best of my knowledge.
New spark plug and cap, good spark, tried known working stator and pick up, shimmed valves to spec and checked valve springs, compression is at 165psi, new battery, grounded nuetral and reverse wires going to motor to frame, cleaned carb 100x and swapped many jets with no change at all. Also tried different carb from another 300ex and still no fix, Drained and cleaned tank, gas cap vent is open and clear, new air filter with lid on, checked exhaust and it's not plugged up, bike has an fmf megamax full exhaust on it. Checked timing 3 different times. Things I have not tried, new cdi, valve seat seals, and alot of voltage testing because I do not really know how. All my toys are always 2 strokes with no batteries or light so I am in unfamiliar territory here and this is driving me nuts! Please any input is helpful!
 
1 - 1 of 1 Posts
Top