Honda ATV Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have a 2020 520cc foreman that cranks and runs fine but after 30-45 run time it shuts down and will not crank. Brought it home and checked connections/plug the next day and everything checked out fine. Cranked up fine several times and ran good until it was ridden for another 30 minutes. Shut down again and will not crank. Bad fuel pump? Any ideas?
 

·
Registered
2020 520 rubicon foot shift
Joined
·
380 Posts
If its the fuel pump you will be able to tell if its working by listening to it, you can here it run for a second when you turn the key on. If its not working you wont hear it running when you try to start it after the atv dies.

There's a recall for the fuel pump on some of the 2020 honda models, yours maybe one of them check with the dealer.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
If its the fuel pump you will be able to tell if its working by listening to it, you can here it run for a second when you turn the key on. If its not working you wont hear it running when you try to start it after the atv dies.

There's a recall for the fuel pump on some of the 2020 honda models, yours maybe one of them check with the dealer.
 

·
Registered
Joined
·
2 Posts
I can here the fuel pump run when I turn on the switch but it still won’t crank until it sits for a while. IDK
Have your local dealer run your vin, it may need a new fuel pump under the recall they are having, it sounds like once your fuel pump heats up it quits out til it cools down again. If you dont think its your fuel pump, put a fuel pressure checker on the line. Spec is 48-50psi at idle
 

·
Registered
Joined
·
4 Posts
If its the fuel pump you will be able to tell if its working by listening to it, you can here it run for a second when you turn the key on. If its not working you wont hear it running when you try to start it after the atv dies.

There's a recall for the fuel pump on some of the 2020 honda models, yours maybe one of them check with the dealer.
Check the coil for ignition. Sounds more like electrical than fuel.
 

·
Registered
Joined
·
1 Posts
I have a 2020 520cc foreman that cranks and runs fine but after 30-45 run time it shuts down and will not crank. Brought it home and checked connections/plug the next day and everything checked out fine. Cranked up fine several times and ran good until it was ridden for another 30 minutes. Shut down again and will not crank. Bad fuel pump? Any ideas?
You might try checking and make sure that the fan is working properly mine did same thing, come find out my wiring was faulty. Fixed it and ON THE ROAD AGAIN :)
 
1 - 11 of 11 Posts
Top