Honda ATV Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,

I have a 2019 Honda rancher 420

After about a year it started having a strange electric issue where when you turn the key the display flashes for a second or 2 and then goes blank. No power, can't start.

Over the course of fiddling with it I found out that if I turned the headlights it would immediately rectify the issue.

Fast forward to now, another year later of ignoring this problem and flipping the lights on to start my machine...the problem is back but the headlight trick no longer works.

The problem: When I turn the key the display comes on for a second and there is a click in the gas tank area, don't hear the fuel pump. I can't get a spark by jumping the solenoid with a wrench like there is no power.

If I hold the starter button when I turn the key the solenoid clicks

Battery is fine - not the issue

Can't find any dirty terminals

No connections are loose

No blown fuses.

I can't get over the headlight thing... could it be the adp-28 condenser unit???
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Problem solved for anyone having similar issues in the future.

It was the display itself causing the issue. Unplugged the screen fixed the issue.

Somehow the bad display was preventing the machine from doing it's startup procedure...

Machine is up and running again minus the display.
 

·
Registered
Joined
·
15 Posts
Problem solved for anyone having similar issues in the future.

It was the display itself causing the issue. Unplugged the screen fixed the issue.

Somehow the bad display was preventing the machine from doing it's startup procedure...

Machine is up and running again minus the display.
How do you unplug the screen? I think my Rancher (2004) may have a similar issue.
 
1 - 3 of 3 Posts
Top