Honda ATV Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I've got a 2014 Honda Trx420 that I'm having some issues with all of a sudden. I don't have very much experience with fuel injection so hoping someone can point me in the right direction. I bought this unit new and I've never had any issues with it ever until now.

When I first start it, it seams to take a few extra cranks to fire up than usual, and then when it does fire it will only run for a second or 2 and then die out right away. Without cycling the key off and on again, I can crank it again and the same thing happens, running a little rough and I want to say I think I can hear the odd puff in the air box and then dies out again. A few more of these and it will start to slowly run a little longer each time, until finally the engine will idle on it's own. After its been idling for a little while and the engine seams to be at operating temps, then it seams to run great, I have no issues with idling or lack of power after that, and I can shut it off and it will start back up right away, unless I let it sit again for a few hours and then it's back to the beginning.

New spark plug, Clean fuel tank, new gas and never sits long enough for the gas to go bad anyway. Battery shows 12 volts and battery tester shows good battery when a load it on. I quickly checked the IACV and looked a little dirty so I cleaned it up and cycled the key with it removed and it spun the way it should. No change. I can hear the fuel pump running as normal when I first turn the key on. Computer isn't flashing any codes or engine light either.

I thought at first that it might be starving for fuel, but seams odd that it would get better once it was running for a while. I thought about changing the fuel filter right away but this model has the filter in the fuel pump and it would be a week at least before I can get a rebuild kit in my hands. Again I lack experience with these new models so I appreciate any and all advice. I use this machine nearly everyday on my farm and with calving coming up soon I need it to be reliable again.
 

·
Registered
Joined
·
2 Posts
Hi,you know I have the same problem as you,I have a 1982 trx 300 and the first time I try to start it up it just cranks and cranks sometime I kill the battery BUT after it gets going I have NO problem starting it's just after it sits for a long time or over night....
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thought I would come back and finish this thread for someone in the future with the same problem although I'm still not sure exactly what my issue was for sure but it's running like a top now. Spark was good and not cutting out so I figured there must be an issue getting fuel. I took the fuel pump out and drained and cleaned the tank as well as the fuel supply and return line and injector. Put everything back together and boom runs like a top. There was definitely some crud in the corner of the tank so even with fresh fuel, if there was a restriction then the engine would starve. Hope this maybe helps someone down the road having the same issue.
 
1 - 3 of 3 Posts
Top