Honda ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2009 TRX 420 with no spark. The problem started with a misfire and eventually the engine would quit but start right up again but still misfire as verified by spark tester. Thinking it was a coil problem I took a spare coil I had from a 2001 Honda TRX 350 and installed it. It started , ran for a few seconds then quit with no power to the switch or panel. Found the Ignition 10 amp fuse was blown, so replaced it and removed the 2001 coil and reconnected the existing coil on the machine. Now I have no spark at all as verified by tester. Have battery voltage at the coil terminals when the key is on but no spark. What did i damage by trying the 2001 coil on this machine ? Could I have damaged the ECM or some other electrical component ?
 

·
Premium Member
Joined
·
38,518 Posts
I highly doubt you swapping coils is/was the problem ?. it very well can be anything from the ecu ?, reg/rec ?, stator ?. all of these is where your spark is. try getting the service manual, and start trouble shooting, and see where it leads ya :).
 

·
Premium Member
Joined
·
38,518 Posts
and welcome to the forums.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Thanks. I have the manual and have done a bunch of tests, but I do not have a voltage peak tester for my multimeter so I cannot check for the peak voltage of 100v minimum at the coil. I have battery voltage but cannot read peak voltage, any resistance readings for the primary and seconary of the coil ?
 

·
Premium Member
Joined
·
38,518 Posts
key on, battery good, you should see a green neutral light on ?, if your not getting a neutral light ?, it won't spark the plug.
 

·
Registered
Joined
·
136 Posts
This might be obvious but has to be asked...... is the air sensor plugged in at the airbox? A 420 will not spark/start without it plugged in.
 

·
Premium Member
Joined
·
38,518 Posts
This might be obvious but has to be asked...... is the air sensor plugged in at the airbox? A 420 will not spark/start without it plugged in.
you can thank Honda for adding all this stupid air sensors, speed sensors, and what ever else that is useless ??!!..lol.you can thank fuel injection for having all this crap on them !..lol. I sure love my old girl ( 1989 trx350D foreman ), she don't have all this wasted electric crap on her !..lmao.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #8 ·
Thanks guys, looked at wiring and a number of things as suggested but gave up and sent it off to the loacl Honda dealer to get it repaired, probably PCM or CDI I am thinking. The blown 10 amp ignition fuse after I ran it for less than a minute with the coil from a 2001 Honda TRX 350 seemed to be the frosting on the cake as it never had spark after that.
 
1 - 8 of 8 Posts
Top