Honda ATV Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Any help would be appreciated. I replaced the fuel pump, Injector, and the relay and I'm still not getting the injector to spit fuel. I can remove the injector and I'm getting plenty of fuel from the pump. I've checked the and there is no issue getting power to the injector. Also I'm getting plenty of spark at the plug, just cant seem to find out why the injector wont release the fuel.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
have the injector hooked up to the harness but out the carb, crank the bike and see if it spits fuel, point it away from ATV and exhaust.
Check your valves and timing.
I’ve already tried it with 2 different (new) injectors and both would not spit fuel.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
interesting, and you are getting power to injector you said?
Yes getting power to the injectors. Before this happened, the bike would run great but on long rides sometimes we would stop for a beer break and if I killed the bike it wouldn’t start. Would have to sit for a bit and then it would crank right up. Then one day we were riding and we stopped for a break and it didn’t crank back up. That’s when I changed the fuel pump, injector, and the relay. It cranked and ran for a bit then I killed it and it hasn’t ran since.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
Have you checked your fuses? all grounds? battery load test, charged?

so right now the bike would crank and try and start but fuel is not getting out of the fuel injector? sorry I'm trying to fully understand the symptoms.
Yes. New battery. New fuel pump with great pressure. All fuses are new. Replay is new. New injector. Bike has proper fire at the spark plug. It just will not spit fuel from the injector. On/off switch seems to be fine. I’ve replaced the fuel injector and the relay twice just in case I was sent faulty parts but that’s not the issue for this time I ordered both through Honda. If I spray gas through the breather the bike does run momentarily til the fumes burn off naturally. Just not sure what else to check for
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
great info thank you. Do you have a service manual?

if the injector sprays out of it when connected to the harness, but not when connected to the throttle body, maybe check the port where it goes into the throttle body?
have you tried holding the throttle a bit while starting?
Yes with the injector connected but in my hand it will not spit fuel. but if I remove the injector plenty of fuel comes out of the line.
 

·
Registered
Joined
·
2 Posts
Did you ever solve the problem? I’m having a similar issue aside from being able to check continuity which I have no idea how to do. I just ordered a injector relay. The bike sat for years fuel system was trashed bike has good spark fuel pump is new clean filter clean canister has fuel at elbow for injector. Runs off gas and starter fluid. Worried it may be pcm but I got the bike for a steal. Just at this point I’m ready to pull my hair out. Any info would be great.
 

·
Registered
Joined
·
336 Posts
Did you ever solve the problem? I’m having a similar issue aside from being able to check continuity which I have no idea how to do. I just ordered a injector relay. The bike sat for years fuel system was trashed bike has good spark fuel pump is new clean filter clean canister has fuel at elbow for injector. Runs off gas and starter fluid. Worried it may be pcm but I got the bike for a steal. Just at this point I’m ready to pull my hair out. Any info would be great.
what are your symptoms?

you said bike runs off gas and starter fluid haha
 
1 - 13 of 13 Posts
Top