Honda ATV Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
2007 fuel injected rancher 420 backfired when I tried to start it. now wont fire up. I have pulled fuel pump change fuel filter and gas. fuel pump pumps gas into bottle and pulled injector and it sprays when you turn over engine. replace spark plug it has spark when grounded to engine or chassis. tried starting fluid still no luck.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
i have low hours on bike only use for hunting. it has ran fine this season until now. don't have compression gauge. when you put finger in spark plug hole has pressure. battery was reading 11.8 volts and would go to 9 volts while trying to start. replaced battery. still not starting . checked ohms of ignition coil 2.3 ohms
 

·
Premium Member
Joined
·
2,608 Posts
PCM / ECM parts are usually replaced only when everything else has been ruled out - not the first thing to replace. Same for the stator, CDI and regulator / rectifier because these are all expensive parts that you don't want to play "Swaptronics" with. Follow the troubleshooting fault tree in the shop manual.

At this point, you need a compression gauge. They are usually free issue for testing purposes at your local auto parts store for a small deposit. Bring it all back in a few days after you are done testing and they give you your money back.

Rick
 

·
Premium Member
Joined
·
6,522 Posts
If you have fuel and spark it has to be timing or compression related. Does it pop at all when you try to start it?

Run a jumper wire from battery + to the red and black wire on the coil. That will bypass several computer cutouts on the ignition.

Is the N light lit up when you're trying to start it?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
i have performed a compression test. it is with in specs of manual. 73 it has a decompression device on the cam. it has slight pop if you barely touch the throttle. about preform some of the voltage test I don't think my meter will pick-up peak voltage reading. it does seem like a timing problem.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #9 ·
tested fuel voltage and shut off relay everything normal. tried peak voltage test without adapter meter does not seem to pick up peak voltage 0.073 need to build or by adapter. N light stays on when cranking. Also tried jumper.
 

·
Registered
Joined
·
1,419 Posts
tested fuel voltage and shut off relay everything normal. tried peak voltage test without adapter meter does not seem to pick up peak voltage 0.073 need to build or by adapter. N light stays on when cranking. Also tried jumper.
I believe the right reading would be around 73 psi. Have you noticed any blow by or oil in the exhaust and/or changed the oil recently to notice anything out of the ordinary?

Just a side note, the switch on the left side the handle bar grip (the one where you can kill it) is in the run position, correct? I'm asking because this haunted me for a day, LOL...
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #11 ·
no blow by or oil in exhaust. bike was running perfect before this. have an dva ordered to perform some test. just seems like spark and fuel is not in proper timing. tried starting fluid again with know luck actually seems to makes it worst when trying to start.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #13 ·
it seems like it wants to hit and sight pop if you barely touch throttle. When you try starting fluid it seems engine is miss firing and wants to lock -up pull plug clear cylinder put pug back in engine cranks fine. That why i thing it is a timing issue. What controls fuel and spark timing. Hopefully
I will receive dva adapter Tuesday and perform some voltage test. I have been following test from shop Manuel but at this point I need a dva for peak voltage test.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #14 ·
I finally gave up and brought bike to Honda . They told me it is an internal engine problem. (engine jumped timing). They said it is rare on the 420 but does happen. Guess its time to pick up bike and take engine apart to find out why.
 
1 - 15 of 15 Posts
Top