Honda ATV Forum banner

2006 rubicon no spark no neutral light

2091 Views 33 Replies 4 Participants Last post by  retro
Hello I am working on a 2006 Rubicon for a friend. The motor started giving trouble shifting and he was getting a temp warning light. When he shut the bike off it would not turn or pull over. I ended up removing the motor and completely dismantling it to find a 5mm bolt stuck in the oil pump. The bolt came from a divider inside the oil tank. Replaced the oil pump and put the engine back in.
Tried starting the engine today and no spark and the gear position does not read on the dash.
Looking for some help. Should the coil still spark without the neutral light being on
1 - 17 of 34 Posts
No just the broken lines. And no code blinking
Any idea how to trick the gear position sensor
Jumped out the neutral switch and it’s now running. Now I need to pull the switch to check it out.
  • Like
Reactions: 1
Does anyone know what the other sensor is just above the rear output shaft. It’s not connected on this bike. Can’t find it on any of the parts drawings.
The gear position switch is down low on the rear engine cover to the right of the output shaft. It is bolted to the outside so no trouble to change it. The switch or sensor I am asking about is on the rear cover just above the output shaft. I think it might be at speed sensor but I can not find we’re to plug it in.
The first pic is the gear position and I am not sure what the second one is. Can’t find we’re to connect it.


See less See more
Replaced the gear position switch and it started showing the gear position. When I went for a ride I got code 5 and 11 on the bike again. Code 11 was a blown fuse. Replaced it and that code was gone. Code 5 was for the angle sensor, did some checks and found the sensor resistance to low. Replaced it and now when I try to preform the initial setting procedure it will only let me go to step 7. The neutral light should go out and then ——— should start to blink so that the angle sensor can be set up. Anyone know why I can’t get past step 7.
It was OEM but used. I will try unhooking the battery
Now have a problem with code 11 again. Have done all the checks for code 11 and found nothing. When I plug the 5P connector back in on the ECM the 30 amp fues blows. Any way to test the ECM.
It’s all OEM. The fuse blows when I plug in the angle sensor. I have tried another sensor and same thing. All wiring had been check and good. Even when the sensor is removed from the bike it will blow the fuse. Looking for help on this one. Please.
Done some more testing and connected a test light to fuse holder instead of the fuse to check for the dead short. With the sensor connected it goes to short for about 3 seconds when you turn the key on. Does not go to short with the sensor unplugged. If I turn the shaft in the sensor about 3/4 way and turn the key on there’s no short. How should the angle sensor work. I have it installed preloaded also.
Not getting much help with the post. Got to be someone out there that can help
I replaced the gear position switch and that is working fine now.
The New problem is now I am blowing the ES motor fuse Shen I turn the key on.
If I unplug the angle sensor or the 21P black con Tom the ECM the fuse is fine.
Is the G/Y wire ground on the angle sensor?
I am getting the correct voltage from G/Y to B/R.
When I turn the key on the B/R goes to ground. Should this be happening. I have replaced the angle sensor so I am thinking the the ECM is gone.
Angle sensor is OEM and all tests are good with 5 volts position from B/R to motor ground and 4.99 from B/R to Y/G. Resistance test good and motor gear turns freely.

Gear position is installed correctly and all wires test fine.

All gear switches test good.
I did some more testing tonight and found that if I removed the 10 amp ignition fues the 30 amp es fuse was fine.
I used a test light in place of the fuse and it goes to ground for about 3 seconds after turning the key on. Same happened when I installed the 10 amp fuse. After I tried this a few times the 30 fuse didn’t blow anymore. I have no idea why.
Now I have a new problem. I am now getting code 4. I have done all the tests on the TP sensor and no problem found.

Tried to do the initial set up again and can get all the way to step 8 but motor does not turn. No voltage getting to the motor. Tested all wiring for the motor and all ok. Removed motor and took it apart all tested good. Connected motor to 12 volts. It turned but wires got hot after a few seconds of turning. Maybe it the motor that is causing the codes.
See less See more
  • Like
Reactions: 1
Looked good and I tested the motor internals. Why wouldn’t I be getting voltage on the motor wires during initial setting
1 - 17 of 34 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.