Honda ATV Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I've met my match, my rancher flashes 2 times and will not shift once the blinking starts. I brought it to a local shop and the guy swore it was the angle sensor. I figured why not and I purchased a new one and installed it. Didn't fix anything. So I looked online, it suggests the ecu, the new one just arrived and....nope. Here's why I'm confused, it's not permanently flashing and just a few moments ago I figured out what's causing it to start blinking. Once I apply the left (es shift side) break or the foot break the blinking starts. I have a hand break on the right side and it does not cause the blinking. I'm confused at this point and the closest mechanic is over an hour away (minus the local guy who let me artery and was the reason for wasting money). Does anyone have any advice for me on what to look for?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
I still haven't fixed the issue. But while only using the brake on the right handle I was able to run it around for about the last half hour with no problems. But as soon as I used the brake on the left handle the two flashes started again. I'm open to any and all ideas for a possible solution
 

·
Super Moderator
Joined
·
38,518 Posts
I am not sure about the trx350 ranchers having issues with the front left brake lever ?, but I think the newer trx420's have it where you could pull the left brake lever ( or was it the right front ? ), and start it in gear ?. if this is the case ?, was the lever changed out at one point from another atv ?. I have never heard of any trx350 ranchers have the brake lever tied to the ecu ?, unless it's something on the late models ?.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
I purchased used, but it barely had any miles on it. It only has around 2000 miles after this long. I don't understand it either, for the break to be the reason the atv stops working has me all types of confused at this point.
 

·
Super Moderator
Joined
·
5,062 Posts
I am not sure about the trx350 ranchers having issues with the front left brake lever ?, but I think the newer trx420's have it where you could pull the left brake lever ( or was it the right front ? ), and start it in gear ?. if this is the case ?, was the lever changed out at one point from another atv ?. I have never heard of any trx350 ranchers have the brake lever tied to the ecu ?, unless it's something on the late models ?.
Just for reference purposes 420's will start in gear with the front (right) pulled back.
 

·
Registered
Joined
·
2,924 Posts
Hi: Remove the 15 amp light fuse and try again.
 

·
Registered
Joined
·
2,924 Posts
I tried removing the fuse. Oddly after removing it I was unable to even start the atv?
Are the fuses in the right places?
30 Motor
30 Main
15 Light
10 Ign
15 Fan
15 Acc
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
They are. Your advice helped though, after what you said I thought I'd try to actually disconnect the brake lights. So I removed the wires from the front handlebar and the foot break. Well I don't have brake lights now but the problem seems to have stopped. But now I've ran into another issue. It's getting stuck in neutral, it revs up a little then locks into neutral, I swear if it's not one thing it's another
 

·
Registered
Joined
·
2,924 Posts
This bike you have is a 2006 TRX350 es??
Is there any other electrical things added to the bike?
 

·
Registered
Joined
·
5 Posts
I have one doing the same thing.
Did anyone update or have a link referencing the fix for this? Seems like I've tried everything and have same year/make and doing the same thing! Interestingly, when I go to the camp and ride it does this all the time...to the point it does it even when riding and the gear starts blinking. It's getting very annoying. To the point, I've started having to just leave it in 3rd gear so that I can at least keep riding without shutting it down and resetting all the time or using the manual shifter constantly. However, once I bring it home in the garage, I cannot replicate it. Seems odd! Any updates or findings would be appreciated. (blinking twice).
 
1 - 20 of 22 Posts
Top