Honda ATV Forum banner

1 - 20 of 42 Posts

·
Registered
Joined
·
282 Posts
Discussion Starter #1
My 2005 Honda Rancher AT has a big problem. It will work well untill it gets up to about 28 mph, then it revs up really high but only gets up to 34-35mph. It's acting like it can't hit the next gear. Does anyone else have this problem or know what it is, or anything about it? I'd love some help if you have it

I've taken it to yamaha of beaufort and yamaha/Honda of Savannah and they both told me it was fixed, charged me for something they did, and it wasn't fixed at all. Yamaha of beaufort charged me $600 for a clutch rebuild
 

·
Registered
Joined
·
1,873 Posts
Are you getting any blinking error codes at all?
 

·
Registered
Joined
·
182 Posts
:icon_ nono2:I would ask around and find a good mechanic w/ good reliable service & see what they think before i let any one else "work" on it!!!!!
 

·
Registered
Joined
·
282 Posts
Discussion Starter #6
Ah well tryin to stay calm about it, don't want assault charges on me. lol
No I'm not getting any error codes. Nothing out of the ordinary on the screen.
 

·
Premium Member
Joined
·
6,616 Posts
If they charged you to fix a problem and it's not fixed, they need to eat the bill. Unless you went and told them it needs a new clutch.

Not to sure what would cause that.
 

·
Registered
Joined
·
282 Posts
Discussion Starter #9
Yeah so would I honestly, but my dad is in charge of the repairs. He hasn't told either of the dealers that the problem wasn't fixed, he hasn't taken it back and chewed them out or anything!!! I myself would have gotten my money back or ATLEAST told them that they f*cked up. But anyway does anyone have any advice other than punching someone in the face?:icon_twisted:
 

·
Premium Member
Joined
·
6,616 Posts
LMAO, Sorry I'm stumped
 

·
Registered
Joined
·
1,280 Posts
Yeah so would I honestly, but my dad is in charge of the repairs. He hasn't told either of the dealers that the problem wasn't fixed, he hasn't taken it back and chewed them out or anything!!!
Your father obviously has more money that he needs, so I would petition for a whole new bike. Seems reasonable.

As to your problem, sorry I can't help, but if I were your dad, I'd be missing a right boot, because it would planted up someones ass right now.
 

·
Registered
Joined
·
282 Posts
Discussion Starter #12
Nah we definitly aren't rolling in money. It's been two years since the beaufort yamaha trip and he just decided to take it to Honda of Savannah. I'm not sure why he won't say anything about it, but it's definitly not that he has tons of money at his disposal.

I found another user that has this problem but I havnt gotten in touch with him to see if he has found a resolution.
 

·
Premium Member
Joined
·
5,847 Posts
Regardless, somebody needs to call the service men.....Period! They are out of line if they do not correct the problem. I know a shop here that warranties thier work. but if he don't know about it he can't fix it..
 

·
Registered
Joined
·
282 Posts
Discussion Starter #15
Yea I know. I'm not sure of any out-of-ho
e good local atv mechanics though

and I'll try not to XD
 

·
Registered
Joined
·
1,873 Posts
What mode are you running in? ESP?? AT??
 

·
Registered
Joined
·
282 Posts
Discussion Starter #20
XD is a laughing smiley. Look at it with ur head turned sidewards.

I generally use automatic, but I tried it in ESP and it still didn't change anything.
 
1 - 20 of 42 Posts
Top