Honda ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
New to the forum...so im hoping some one can shed some light on this for me.....Everything has just been cleaned and serviced..... mid ride noticed the clutch handle had a little to much play in it. I adjusted accordingly. Now when driving down the road as you pull the clutch the bike dies...
Is it possible that it has something to do with my clutch?? I can start the bike with the clutch engaged but it seems to labour a little. I've checked the wiring for the kill switch it all seems good. Not sure where to go from here!!!!! Thanks in advance
 

·
Super Moderator
Joined
·
38,518 Posts
if I were to guess ?, i'm gonna say your clutch is not adjusted right, and its stalling out. in other words, your clutch is not releasing from engagement when you pull the clutch lever.
 

·
Premium Member
Joined
·
4,389 Posts
I gave my best answer on your other thread. Please refrain from making multiple threads about the same problem. It dosnt get answers any faster that way.

But i highly doubt its anything to do with your clutch itself. It has to be something killing spark to the motor. Does it make any difference if you hold throttle on while shifting? I know that sounds weird but if the idle drops to quick it could be choking out and dying. If holding throttle dosnt make a change its losing spark for some reason with the clutch pulled.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
"SlammedRanger" just didn't want to clog up the wrong section of the forum...figured I better post in the right area. Thank you for the replies....have to dig deeper on the weekend
 

·
Premium Member
Joined
·
4,389 Posts
No worries! Keep us posted!
 
1 - 5 of 5 Posts
Top