Honda ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
347 Posts
Discussion Starter #1
i was coming back from a friends house today, I pulled in the clutch to roll down the hill and the engine died. I let out the clutch and started it back up and when i hit the gas, i got no power. So i switched it to reserve and it ran like a charm. and about a half mile down the road the lights went out. So i drove it the rest of the way home. when i got home i turned it off, and tried to start it and a rapid clicking sound came from the battery. What is the problem??? Blown fuse??? Seloniod??? I NEED IT WORKING BY THIS WEEKEND!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 

·
Registered
Joined
·
6 Posts
sounds like the batt was low charge the batt and start it up and check output voltage at the batt with a volt meter should be aboult 14.5 volts at 4 to 5 thousand maybe this will help you out
thanks aces atv
 

·
Registered
Joined
·
2,735 Posts
Something is grounding out.It sounds like the battery drained so much that the stator fried or something because the lights shouldn't have went out.
 

·
Premium Member
Joined
·
23,581 Posts
Agree, the lights should burn, even if there wasn't a battery in it, if it is charging.
 

·
Super Moderator
Joined
·
18,227 Posts
I'm going to have to agree ^^^^ sound like you might have lost a regulator
 

·
Registered
Joined
·
347 Posts
Discussion Starter #6
What part would I need???
 

·
Super Moderator
Joined
·
18,227 Posts
Voltage regulator but I would invest in a manual the told you the specific test procedures for each component oh and a good multi--meter. chasing an electrical issue coould get very expensive.
 

·
Registered
Joined
·
2,735 Posts
I'm gonna say a stator ring.It charges the lights and battery.
 
1 - 8 of 8 Posts
Top