Honda ATV Forum banner

fuel pump

  1. 2008 Honda Rancher 420 4x4 Lost Spark & No Power To Fuel Pump

    Repair & Maintenance
    Just recently bought a 2008 Honda Rancher 420 4x4 for my stepbrother for $1000. It supposedly has a fresh top end rebuild. It was running great up until the other night, not even 30 minutes into riding it, after we got to the mudpark. My stepbrother hit a hard bump, and it died. I noticed that...
  2. HELP! 2009 Honda Rancher FA WONT START fuel issue

    Repair & Maintenance
    Model: 2009 Honda Rancher FA It will fire right up with starting fluid sprayed into the intake. It seems like it’s not getting fuel. I replaced the fuel petcock and drained/cleaned the fuel tank. The old petcock stem rotted out in the tank and I figured it clogged the fuel lines. Fuel pump...
  3. 420 fuel pump problems

    Honda Rancher
    October 2019 I bought a 2013 420 Rancher FPE ES PS. One owner it had 680 miles and 191.1 hours. It run great, but after driving 20 MPH in 4th gear for about 3 to 5 miles it starts surging, skipping (no backing firing). Stop and let it cool off it runs fine for about 15 minutes and starts doing...
  4. Rincon no power to fuel pump

    Repair & Maintenance
    Hey all. I have an 07 rincon that would die Intermittently and now is just dead. It will frank over done but no power to the fuel pump and you never hear the fuel pump or feel it. I cannot find he fuel pump relay or any reference to its location. It's a brand new fuel pump. btw the bike is a...
  5. 1989 TRX350D fuel pump question

    Repair & Maintenance
    I am trying to figure out a problem I am having with my fuel pump on my 89 TRX350D. At first the 4wheeler started stalling out and I could not hear the pump running. I replaced the pump with a Mr Gasket low pressure pump but it runs all the time when the key is on. The oem pump never did...
  6. Gas Tank; Pump,,,etc. Help Please !

    Repair & Maintenance
    In advance, thanks for your time and suggestions ---- great forum: TRX-350D (87'). Very low hours. Has been sitting for a couple of years. We replaced filter (was filled with mush) ,plug,gas. Started right up and then died. Bypassed tank and fed gas directly to cab, ran well. Soooo...
Top