2007 420FM electric shift- no gear display - Honda ATV Forum
Honda Rancher Discuss all models of the Honda Rancher 350/400/420

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 05-27-2019, 02:57 PM Thread Starter
Junior Member
 
2007honda420's Avatar
 
Join Date: Mar 2019
Posts: 7
2007 420FM electric shift- no gear display

Hello, I have changed shift angle sensor, tested gear switch, tested continuity on wiring from gear switch to ecm, to display, all ok...still no gear display. What am I missing, please help.
2007honda420 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 05-27-2019, 06:48 PM
Junior Member
 
Hawire's Avatar
 
Join Date: May 2019
Posts: 12
Liked: 9 times
Have you checked your fuse? I’ve got one I’m fighting now. Sometimes it is just the fuse. Of course I find that out after I check everything else
Hawire is offline  
post #3 of 8 (permalink) Old 05-30-2019, 11:12 AM Thread Starter
Junior Member
 
2007honda420's Avatar
 
Join Date: Mar 2019
Posts: 7
All fuses are good
2007honda420 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 05-30-2019, 11:14 AM Thread Starter
Junior Member
 
2007honda420's Avatar
 
Join Date: Mar 2019
Posts: 7
Is there more fuses elsewhere then under seat? Main, ign, fan, acc?
2007honda420 is offline  
post #5 of 8 (permalink) Old 05-30-2019, 01:43 PM
Junior Member
 
Hawire's Avatar
 
Join Date: May 2019
Posts: 12
Liked: 9 times
Not that I know of
Hawire is offline  
post #6 of 8 (permalink) Old 05-30-2019, 01:45 PM
Junior Member
 
Hawire's Avatar
 
Join Date: May 2019
Posts: 12
Liked: 9 times
Have you tested the throttle position sensor? Maybe a long shot, but I can cause the dreaded “- -“ to pop up.
Hawire is offline  
post #7 of 8 (permalink) Old 05-30-2019, 02:23 PM
Senior Member
 
Jeepwm69's Avatar
 
Join Date: Sep 2013
Location: Eastern Arkansas
Posts: 6,276
Liked: 3079 times
Quote:
Originally Posted by 2007honda420 View Post
Hello, I have changed shift angle sensor, tested gear switch, tested continuity on wiring from gear switch to ecm, to display, all ok...still no gear display. What am I missing, please help.
Gear switch could be bad. Display could be bad.
Jeepwm69 is offline  
post #8 of 8 (permalink) Old 05-30-2019, 04:00 PM
Junior Member
 
Hawire's Avatar
 
Join Date: May 2019
Posts: 12
Liked: 9 times
Do you have the service manual for this atv? There is a download on here, somewhere. You’re absolute best bet is to get that. Go through how to get the trouble code section and see what it says about how many flashes you get. That’s the very best way to start. If not, you’re throwing darts blindfolded.
Hawire is offline  
Reply

  Lower Navigation
Go Back   Honda ATV Forum > Honda Model Specific Discussions > Honda Rancher

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome