2011 Rancher 420 AT EPS issue and question - Honda ATV Forum
Honda Rancher Discuss all models of the Honda Rancher 350/400/420

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-07-2019, 03:08 PM Thread Starter
Junior Member
 
pcodding's Avatar
 
Join Date: Jan 2011
Posts: 3
Red face 2011 Rancher 420 AT EPS issue and question

So I'm downloading the service manual as I'm typing. I have a 2010 Rancher I'm working on and the power steering is not working. I did change the 40A fuse, and actually should have tested the first one as it is fine. On Youtube I saw how to reset the power steering unit on a 2014 by jumping the red dummy plug, using a screwdriver to put under the control plate and then turning the handle bar a few times. Is this the same procedure on a 2011? I looked at a service manual on YouTube but didn't find the reset procedure.

Any useful help would be appreciated.

Also, at times the unit "shifts hard" in automatic mode. Also, it doesn't like going into gear in automatic. I'm guessing angle sensor. This machine has 3,700 miles on it and has seen trails from TN,WV,KY and Ohio. So it's not a garage ornament. But it's not beat to crap either. Just well used.

This is a 2011 Rancher 420, Automatic, Power Steering, IRS,

Thanks for any input.

Last edited by pcodding; 05-07-2019 at 03:10 PM. Reason: Wrong year
pcodding is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-08-2019, 02:33 PM Thread Starter
Junior Member
 
pcodding's Avatar
 
Join Date: Jan 2011
Posts: 3
I did the PS reset to the DCT, still doesn't work. Noticed some oil or fluid coming out of the unit. I'm guessing it is shot. I must be one of the few with these issues. But I do understand most Ranchers don't have PS and are ES.
pcodding is offline  
Reply

  Lower Navigation
Go Back   Honda ATV Forum > Honda Model Specific Discussions > Honda Rancher

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Polishing?Buffing Trx 420 FA 2010 on up robndog123 Honda Rancher 8 05-22-2018 09:45 AM
Primer pump issue ? _Wilson_ Repair & Maintenance 29 02-11-2018 05:57 AM
250ex weak spark issue firechicken93 Repair & Maintenance 3 07-26-2017 05:59 AM
Starting Issue jamez71946 Repair & Maintenance 2 03-01-2017 05:57 AM
2001 Rancher 350 charging issue NachoRoto Honda FourTrax 5 07-02-2016 08:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome