Need help!! - Honda ATV Forum
ATV General Discussion General Discussions about Honda ATVs.

 2Likes
  • 1 Post By retro
  • 1 Post By Nkendall7
 
LinkBack Thread Tools
Old 06-03-2019, 05:19 PM Thread Starter
Junior Member
 
Nkendall7's Avatar
 
Join Date: Jun 2019
Posts: 3
Liked: 1 times
Need help!!

Hello everyone,
Just purchased a 2003 Honda rancher 350 es
And I took it for a ride yesterday and when I was heading back to my house, the four wheeler shut off completely .. I turn the key off and back on again but nothing would display and I couldn’t turn it back on , I’ve check my battery power and it’s where it needs to be , I’ve changed all of my fuses thinking maybe I blew a fuse but those are all fine , I was thinking maybe the key ignition so I’ve ordered one of those but I was just wondering if someone has had this happen to them and could help me out !!

Last edited by retro; 06-03-2019 at 05:28 PM. Reason: language
Nkendall7 is offline  
Sponsored Links
Advertisement
 
Old 06-03-2019, 05:30 PM
Super Moderator
Supporting Member
 
retro's Avatar
 
Join Date: Mar 2017
Location: Ojibwe Gichigami
Posts: 5,438
Liked: 2871 times
You may have solved the problem already with a new OEM Honda ignition switch on order.


retro is offline  
Old 06-03-2019, 05:39 PM
Super Moderator
Supporting Member
 
retro's Avatar
 
Join Date: Mar 2017
Location: Ojibwe Gichigami
Posts: 5,438
Liked: 2871 times
In the meantime you can check that ignition switch for continuity. Make sure you are buying a genuine Honda switch and not a china knockoff, else you're gonna be buying again right away.
Attached Thumbnails
Click image for larger version

Name:	ign-sw.png
Views:	5
Size:	176.3 KB
ID:	137042   Click image for larger version

Name:	2000-thru-2003-Rancher-FE-Wiring.png
Views:	4
Size:	701.9 KB
ID:	137044  
_Wilson_ likes this.


retro is offline  
Sponsored Links
Advertisement
 
Old 06-03-2019, 06:43 PM Thread Starter
Junior Member
 
Nkendall7's Avatar
 
Join Date: Jun 2019
Posts: 3
Liked: 1 times
Okay thanks for the help ! I’ll check that right away and see if it helps 👍
retro likes this.
Nkendall7 is offline  
Old Today, 09:44 AM Thread Starter
Junior Member
 
Nkendall7's Avatar
 
Join Date: Jun 2019
Posts: 3
Liked: 1 times
Tried the new ignition switch but it didn’t fix the problem , still have no display and unable to start it
Nkendall7 is offline  
Old Today, 11:15 AM
Senior Member
 
mrbb's Avatar
 
Join Date: Oct 2011
Location: NE Pa
Posts: 7,871
Liked: 1956 times
kill switch is in RUN and didn;t get bumped to off did it?

when you say atv just stopped, did it make any funny noises before shutting down?, was there a LOT of heat coming from motor?
when you say battery is good, , HOW do you know this, did you have it load tested. or did you just use a meter for the reading of 12 volts??
mrbb is online now  
 

  Lower Navigation
Go Back   Honda ATV Forum > Honda ATV Discussions > ATV General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome