Honda ATV Forum
Go Back   Honda ATV Forum > Honda ATV Technical Discussions > Repair & Maintenance

Repair & Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

Reply
 
LinkBack Thread Tools Display Modes
Old 11-01-2010, 04:22 PM   #1 (permalink)
Junior Member
 
zukryder's Avatar
 
Member #5882
Join Date: Oct 2010
View zukryder's Photo Gallery(0)
Posts: 6
2006 rubicon

I have a honda rubicon that after an hr or so of riding it acts like the transmission is sticking. It is if i throw it in neutral. I let it sit for 5 to 10 mins. and the it runs find for the next 10 mins or so, then it acts up again. I need some ideas for trouble shooting. I think it might be the clutches, but not a 100% sure. Please let me know what you guys think. thx.
zukryder is offline   Reply With Quote
HondaATVForums.net is the premier Honda ATV Forum on the internet. Registered Users do not see these ads, so Register - It's Free!
Reply

Lower Navigation
Go Back   Honda ATV Forum > Honda ATV Technical Discussions > Repair & Maintenance

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Discount Tire
Motosport.com


Powered by vBadvanced CMPS v3.2.1
All times are GMT -6. The time now is 03:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.