07 Honda Rancher ES tranny problem - Honda ATV Forum
Honda Rancher Discuss all models of the Honda Rancher 350/400/420

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-12-2011, 03:51 PM Thread Starter
Junior Member
 
Hondaboss420's Avatar
 
Join Date: Jan 2011
Posts: 12
07 Honda Rancher ES tranny problem

I have an '07 Honda Rancher 420 ES for about 2 years, and now have this transmission problem. Some people says its a bent shifting for which I've heard is a problem on some models, sadly stupid honda won't cover the money. When I shift into 3rd and hit the gas it skips alot, and now 4th gear just grinds and jumps back to 3rd. Gears 1,2, and 5 work only. The Clutch is adjusted fine. The rear brake was stuck on here and there but it would let off as soon as you got up above 5 MPH. That probobly put some wear on something. I'm going to have it looked at by a mechanic but wanted to see what other people had to say.
Hondaboss420 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Honda ATV Forum > Honda Model Specific Discussions > Honda Rancher

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome