ECU problem? - Honda ATV Forum
Honda Rancher Discuss all models of the Honda Rancher 350/400/420

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-06-2012, 08:01 PM Thread Starter
Junior Member
 
45jaxin's Avatar
 
Join Date: Feb 2012
Posts: 1
ECU problem?

My 2002 Rancher 350ES suddenly has no electronics. Display panel is blank, no electric start. But it will pull start and run fine and the ES will work briefly before stopping. I replaced the battery hoping it would be that easy. All fuses are fine too. I'm thinking it's the ECU. Any thoughts/suggestions before I buy a new one?
45jaxin is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Honda ATV Forum > Honda Model Specific Discussions > Honda Rancher

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome